10-16-16

 

Hello,

So this past weekend I ran into an issue where a Cisco 3750G wast establish a Etherchannel connection between two 3750G’s in L2 when the switch by default has L3 enabled on a Etherchannel. I wanted force a L3 connection between the two 3750G at the Core and the two 3750G at the Distro Layer and make all the connections L3 and completely remove L2 designs from the routable portions.

Everyone online says to just do the following on a L2 Etherchannel for multiple vLAN’s or a Trunk:

Interface Port Channel 2

switchport mode trunk

switchport trunk encapsulation dot1q

OR do the following on a L2 Etherchannel for a single vLAN or a Access:

Interface Port Channel 2

switchport mode access

switchport access vlan [X]

and then on the interface such as “interface gigabitethernet 1/0/1” for a access:

Interface gigabitethernet 1/0/1

switchport mode access

switchport access vlan [X]

channel-group 2 mode (on or active)

and then on the interface such as “interface gigabitethernet 1/0/1” for a trunk:

Interface gigabitethernet 1/0/1

switchport mode trunk

switchport trunk encapsulation dot1q

channel-group 2 mode (on or active)

But what I wanted was to NOT use a L2 Etherchannel but a L3 Etherchannel, which has a faster reconnection speed and negotiation speed. Essentially I wanted to make the connection between all of the 3750G’s a L3 tunnel vs a L2 tunnel. Fully Utilizing the benefits of L3 routing protocols.

Example on a 3750G:

Interface Port Channel 2

no switchport

ip address [IPv4 address] [/30 Subnet Mask]

on the interface in question:

Interface gigabitethernet 1/0/1

no switchport

no ip address

channel-group 2 mode (on or active)

Once this was setup the connection between the 3750G’s where set to an inherent L3 Etherchannel instead of a L2 Etherchannel.

The L3 routing protocol of OSPF and EIGRP was used as the communication protocol between the 3750G’s which in my opinion is a self-healing communication protocol. If it was a switchport enabled L2 Etherchannel then you need to worry about spanning-tree. Essentially what you make it a Spine/Leaf connection instead of a traditional 3 Tiered architecture.

Only note is to make sure the connection betwen the switches is a /30 or a 252 in the 4th octet or is even simplistic terms 4 IP address, one in the network ID and the last is the broadcast ID. Since you only need two connections it makes for better use of IPv4 addressing.

Personally, for me, all networks I use are moving towards a Spine/Leaf configuration and I just use a L3 switches actually ports are L2 vLAN domains and actual L3 traffic is routed between the Spine and Leaf L3 switches. Reducing Spanning-tree design considerations.

If you run into an issue where you switch doesn’t form a LACP connection with multiple vLAN’s into a VMware deployment on the LACP refer to this link:

https://www.g15it.com/networking-cisco-3750-enabling-src-dst-ip-etherchannellacp-vmware-ip-hash/